1

Topic: Question under versions.net framework

Colleagues, prompt, whether here correctly I understand, what for start of the software written with usage.net 4.5 (the version selected from project properties), on the computer too should be installed.net 4.5? Or there there is any possibility to use 4.5 for the assembly, but to make the assembly binary-compatible with 4.0? Is some  a software, at present all source codes gather under.net 4.0 It would be desirable to creep at least on 4.5, but there are fears that we can have users with Windows XP, and for XP 4.5 is not accessible.

2

Re: Question under versions.net framework

Hello, Artem Korneev, you wrote: AK> Colleagues, prompt, whether here correctly I understand, what for start of the software written with usage.net 4.5 (the version selected from project properties), on the computer too should be installed.net 4.5? Yes. AK> Or there there is any possibility to use 4.5 for the assembly, but to make the assembly binary-compatible with 4.0? As you it represent it to yourselves? I will write the code under 4.5, and it will be launched under 4.0? If you do not have necessity for features 4.5 easy write on 4.0.

3

Re: Question under versions.net framework

Hello, Artem Korneev, you wrote quirking

4

Re: Question under versions.net framework

Hello, Artem Korneev, you wrote: AK> Colleagues, prompt, whether here correctly I understand, what for start of the software written with usage.net 4.5 (the version selected from project properties), on the computer too should be installed.net 4.5? Yes. AK> Or there there is any possibility to use 4.5 for the assembly, but to make the assembly binary-compatible with 4.0? Is. To specify in project properties 4.0. AK> Is some  a software, at present all source codes gather under.net 4.0 It would be desirable to creep at least on 4.5, but there are fears that we can have users with Windows XP, and for XP 4.5 is not accessible. Collect under both  on server CI. Lacking in 4.0 features 4.5 it is normally possible rather easily . See, for example, https://github.com/rsdn/CodeJam - there even under 3.5 version is, though and in some cut form, but in properties of projects it is specified 4.5.2.... <<RSDN@Home 1.0.0 alpha 5 rev. 0 on Windows 8 6.2.9200.0>>