1

Topic: fedora Error unpacking rpm package

At update received here the such: Performance of transaction Update: glibc-2.23.1-11.fc24.i686 1/8 Error unpacking rpm package glibc-2.23.1-11.fc24.i686 Error unpacking rpm package glibc-2.23.1-11.fc24.i686 an error: archive unpacking is not went right on a file/lib/ld-2.23.so; 58283e44: cpio: open Update: libXi-1.7.8-2.fc24.i686 2/8 Error unpacking rpm package libXi-1.7.8-2.fc24.i686 Error unpacking rpm package libXi-1.7.8-2.fc24.i686 an error: glibc-2.23.1-11.fc24.i686: to install failed an error: archive unpacking is not went right on a file/usr/lib/libXi.so.6; 58283e44: cpio: symlink Update: libpng-2:1.6.26-1.fc24.i686 3/8 Error unpacking rpm package libpng-2:1.6.26-1.fc24.i686 Error unpacking rpm package libpng-2:1.6.26-1.fc24.i686 an error: libXi-1.7.8-2.fc24.i686: to install failed an error: archive unpacking is not went right on a file/usr/lib/libpng16.so.16; 58283e44: cpio: symlink Update: pcre-8.39-6.fc24.i686 4/8 Error unpacking rpm package pcre-8.39-6.fc24.i686 Error unpacking rpm package pcre-8.39-6.fc24.i686 an error: libpng-2:1.6.26-1.fc24.i686: to install failed an error: archive unpacking is not went right on a file/usr/lib/libpcre.so.1; 58283e44: cpio: symlink glibc-2.23.1-11.fc24.i686 should be installed, but has not been installed! Check: glibc-2.23.1-11.fc24.i686 1/8 libXi-1.7.8-2.fc24.i686 should be installed, but has not been installed! Check: libXi-1.7.8-2.fc24.i686 2/8 libpng-2:1.6.26-1.fc24.i686 should be installed, but has not been installed! Check: libpng-2:1.6.26-1.fc24.i686 3/8 pcre-8.39-6.fc24.i686 should be installed, but has not been installed! Check: pcre-8.39-6.fc24.i686 4/8 pcre-8.39-3.fc24.i686 should be remote, but has not been remote! Check: pcre-8.39-3.fc24.i686 5/8 libXi-1.7.7-1.fc24.i686 should be remote, but has not been remote! Check: libXi-1.7.7-1.fc24.i686 6/8 libpng-2:1.6.23-1.fc24.i686 should be remote, but has not been remote! Check: libpng-2:1.6.23-1.fc24.i686 7/8 glibc-2.23.1-10.fc24.i686 should be remote, but has not been remote! Check: glibc-2.23.1-10.fc24.i686 8/8 Failure: glibc.i686 2.23.1-11.fc24 libXi.i686 1.7.8-2.fc24 libpng.i686 2:1.6.26-1.fc24 pcre.i686 8.39-6.fc24 How to treat?

2

Re: fedora Error unpacking rpm package

With local HDD/SSD all is good?  yum clean all after ' fsck-t-y-f-c/dev/sdaX ' [check on a subject bad blocks]. It is possible fsck to replace on two commands: badblocks-v-s/dev/sdaX> badblocks.log e2fsck-l badblocks.log/dev/sdaX Certainly/dev/sdX should be beforehand . Well with livecd it not a problem, if a problem at you on  versions fedora. There is all the same a feeling that there are any problems with a disk... Hello, 13akaEagle, you wrote: E> At update received here the such: E> Performance of transaction E> Update: glibc-2.23.1-11.fc24.i686 1/8 E> Error unpacking rpm package glibc-2.23.1-11.fc24.i686 E> Error unpacking rpm package glibc-2.23.1-11.fc24.i686... E> Failure: E> glibc.i686 2.23.1-11.fc24 libXi.i686 1.7.8-2.fc24 libpng.i686 2:1.6.26-1.fc24 pcre.i686 8.39-6.fc24 E> How to treat?

3

Re: fedora Error unpacking rpm package

Hello, K1RA, you wrote: KRA> With local HDD/SSD all is good? KRA> Poporobujte yum clean all after ' fsck-t-y-f-c/dev/sdaX ' [check on a subject bad blocks]. KRA> It is possible fsck to replace on two commands: KRA> badblocks-v-s/dev/sdaX> badblocks.log KRA> e2fsck-l badblocks.log/dev/sdaX KRA> Certainly/dev/sdX should be beforehand . KRA> Well with livecd it not a problem, if a problem at you on  versions fedora. KRA> There is all the same a feeling that there are any problems with a disk... sda1 somehow at all it did not want to be checked [root@192 ~] # fsck-t-y-f-c/dev/sda1 fsck from util-linux 2.28 e2fsck 1.42.13 (17-May-2015) Checking for bad blocks (read-only test): 0.00 % done, 0:00 elapsed. (0/0/0 errdone/dev/sda1: Updating bad block inode. Pass 1: Checking inodes, blocks, and sizes Pass 2: Checking directory structure Pass 3: Checking directory connectivity Pass 4: Checking reference counts Pass 5: Checking group summary information/dev/sda1: ***** FILE SYSTEM WAS MODIFIED *****/dev/sda1: 447/128016 files (2.2 % non-contiguous), 196984/512000 blocks Ran root and home [root@192 ~] # fsck-t-y-f-c/dev/rfremix_192/root fsck from util-linux 2.28 e2fsck 1.42.13 (17-May-2015) Checking for bad blocks (read-only test): done/dev/mapper/rfremix_192-root: Updating bad block inode. Pass 1: Checking inodes, blocks, and sizes Pass 2: Checking directory structure Pass 3: Checking directory connectivity Pass 4: Checking reference counts Pass 5: Checking group summary information/dev/mapper/rfremix_192-root: ***** FILE SYSTEM WAS MODIFIED *****/dev/mapper/rfremix_192-root: 346729/3276800 files (0.5 % non-contiguous), 5559172/13107200 blocks [root@192 ~] # fsck-t-y-f-c/dev/rfremix_192/home fsck from util-linux 2.28 e2fsck 1.42.13 (17-May-2015) Checking for bad blocks (read-only test): done/dev/mapper/rfremix_192-home: Updating bad block inode. Pass 1: Checking inodes, blocks, and sizes Pass 2: Checking directory structure Pass 3: Checking directory connectivity Pass 4: Checking reference counts Pass 5: Checking group summary information/dev/mapper/rfremix_192-home: ***** FILE SYSTEM WAS MODIFIED *****/dev/mapper/rfremix_192-home: 158474/27090944 files (1.3 % non-contiguous), 50953594/108335104 blocks Probably the error appeared after pressure suddenly disappeared. What it is possible to undertake?

4

Re: fedora Error unpacking rpm package

Hello, 13akaEagle, you wrote: E> Probably the error appeared after pressure suddenly disappeared. E> that else it is possible to undertake? If the system somehow was rigidly ungeared in the course of update it is possible to try to rebuild basis RPM. Probably already tried... But just in case: Two variants (though in general this one and too, only a little bit different "words"): the Variant 1: 1. Just in case - backup bases: rsync-avpr/var/lib/rpm/var/lib/rpm.bak 2. Then to delete files and to rebuild basis rm/var/lib / __ db*-fv rpm - rebuilddb the Variant 2: 1. To overload all packets cd/var/lib/rpm mv Packages Packages.bak db_dump Packages.bak | db_load Packages 2. To check up rpm-qa 3. To rebuild rpm - rebuilddb

5

Re: fedora Error unpacking rpm package

Hello, K1RA, you wrote: KRA> If the system somehow was rigidly ungeared in the course of update it is possible to try to rebuild basis RPM. KRA> Probably already tried... But just in case: KRA> Two variants (though in general this one and too, only a little bit different "words"): KRA> the Variant 1: KRA> 1. Just in case - backup bases: rsync-avpr/var/lib/rpm/var/lib/rpm.bak KRA> 2. Then to delete files and to rebuild basis KRA> rm/var/lib / __ db*-fv KRA> rpm - rebuilddb did not help KRA> the Variant 2: KRA> 1. To overload all packets KRA> cd/var/lib/rpm KRA> mv Packages Packages.bak KRA> db_dump Packages.bak | db_load Packages db_load: BDB1540 configured environment flags incompatible with existing environment KRA> 2. To check up rpm-qa KRA> 3. To rebuild rpm - rebuilddb