1

Topic: under how to adjust Selendroid+php

Kind time of days.
I am not , only in the course of study.
I work on Linux Mint and with the help webdriver from facebook+php it was possible to make the task of check of a resource under chrome and firefox.
But here the problem consists that it is necessary for me to make operation with check under different devices (in particular under ) and with different  addresses, i.e. with usage .
I try to implement operation Selenium with check under . I so understood that it is possible to implement it by means of Selendroid
I do the following:
1. Downloaded selendroid-standalone-0.17.0-with-dependencies.jar and selendroid-test-app-0.17.0.apk and added in a project root
2. Installed Android sdk
3. Installed (as it is specified in the documentation - http://selendroid.io/setup.html) the following
sudo dpkg - add-architecture i386
sudo apt-get update
sudo apt-get install libc6:i386 libncurses5:i386 libstdc ++ 6:i386
4. In PATH registered ways <home_path>/sdk/android-sdk-linux/platform-tools:<home_path>/sdk/android-sdk-linux/tools:<home_path>/sdk/android-sdk-linux/build-tools/22.0.1/
5. JAVA SDK it is installed, added in ANDROID_HOME a way to sdk Android and in JAVA_HOME a way to java sdk (/usr/lib/jvm/java-7-openjdk-amd64)
6. Launched android sdk and into consoles entered a command java-jar selendroid-standalone-0.17.0-with-dependencies.jar-app selendroid-test-app-0.17.0.apk
7. Further launched on performance php a script.
In php a script such lines
<? php
$host = ' http://localhost:4444/wd/hub ';
$desired_capabilities = DesiredCapabilities:: android ();
$driver = RemoteWebDriver:: create ($host, $desired_capabilities);
And here there is a problem in the console the error is deduced
[Facebook\WebDriver\Exception\SessionNotCreatedException]
Error starting Selendroid session
It is impossible to launch session. Before it worked with selenium-server-standalone-2.53.1.jar and session was launched all worked, and here with selendroid it is impossible. Prompt, please, in what there can be a problem.