1

Topic: The debugger in VS broke

Does not show value of variables. Though it explicitly is, is described by two lines above and to it value is appropriated. However the debugger it does not see - Error: symbol "res" not found. Shows only this and constants declared in a class.  does not help. What could I break in it?

2

Re: The debugger in VS broke

7> does not show value of variables. Though it explicitly is, is described by two lines above and to it value is appropriated. However the debugger it does not see - Error: symbol "res" not found. Shows only this and constants declared in a class.  does not help. What could I break in it? You debug in release or ? At me in release at  pretty often such happens - does not show variables. At me studio 2012.

3

Re: The debugger in VS broke

Hello, LaptevVV, you wrote: LVV> you Debug in release or ? Certainly in  LVV> at me in release at  pretty often such happens - does not show variables. At me all was shown, I made something with the project, as a result variables disappeared. Removal.pdb and even the full removal Debug with subsequent  does not help.

4

Re: The debugger in VS broke

Hello, 777777w, you wrote: 7> At me all was shown, I made something with the project, as a result variables disappeared. Removal.pdb and even the full removal Debug with subsequent  does not help. Create the new project, compare to its adjustments, especially / ++-> General-> Debug Information Format = Program Database (/Zi) Linker-> Debugging-> Generate Debug Info = Optimize for debugging (/DEBUG) And check up that adjustments for each separate file in the project correspond to project adjustments.

5

Re: The debugger in VS broke

Hello, 777777w, you wrote: 7> At me all was shown, I made something with the project, as a result variables disappeared. Removal.pdb and even the full removal Debug with subsequent  does not help. At level of a mad hypothesis: Perhaps files  somehow hinder? They it is normal in a root . Still a hypothesis: can, in   optimization (especially/Oy turned on (Omit Stack Frames) I would suspect, specially avoid it even in release)

6

Re: The debugger in VS broke

LVV>> At me in release at  pretty often such happens - does not show variables. 7> at me all was shown, I made something with the project, as a result variables disappeared. Removal.pdb and even the full removal Debug with subsequent  does not help. Do not delete files hands.  (clear) the project and .

7

Re: The debugger in VS broke

Hello, 777777w, you wrote: 7> does not show value of variables. Though it explicitly is, is described by two lines above and to it value is appropriated. However the debugger it does not see - Error: symbol "res" not found. Shows only this and constants declared in a class.  does not help. What could I break in it? Good afternoon! Whether you integrated into a Visual Studio Intel products (Fortran in particular). If yes, 90 % that in it the reason. Then it is necessary or to update an Intel product, or to include in adjustments of debugger Compatibility Mode (Tools-> Options-> Debugging: Use Native Compatibility Mode + Use Managed Compatibility Mode)