1

Topic: How to test the assembly under.NET Standard v2?

2

Re: How to test the assembly under.NET Standard v2?

Hello, Kovalenko Dmitry, you wrote: > To the project with NUnit tests the link on nunit.framework.dll (2.6.2) has been added - it normally worked with tests compiled for FW 4.6.2 > Thanks. https://github.com/nunit/docs/wiki/.NET … T-Standard Testing.NET Core or.NET Standard projects requires version 3.8.0 of the NUnit 3 Visual Studios Test Adapter.

3

Re: How to test the assembly under.NET Standard v2?

Hello, QrystaL, you wrote: >> To the project with NUnit tests the link on nunit.framework.dll (2.6.2) has been added - it normally worked with tests compiled for FW 4.6.2 >> Thanks. QL> https://github.com/nunit/docs/wiki/.NET … T-Standard QL> QL> Testing.NET Core or.NET Standard projects requires version 3.8.0 of the NUnit 3 Visual Studios Test Adapter. Aha, thanks. Added. Here it now got out: [11/3/2017 of 9:14:39 AM Error] The operation failed as details for project lcpi.lib.ntest.vs2017s2.0 could not be loaded. [11/3/2017 OF 9:14:41 AM Informational]------ Load Playlist started------ [11/3/2017 OF 9:14:41 AM Informational] ========== Load Playlist finished (0:00:00,0025007) ========== [11/3/2017 OF 9:14:43 AM Informational]------ Discover test started------ [11/3/2017 OF 9:14:44 AM Informational] NUnit VS Adapter 2.1.1.0 discovering tests is started [11/3/2017 OF 9:14:44 AM Warning] Dependent Assembly netstandard, Version=2.0.0.0, Culture=neutral, PublicKeyToken=cc7b13ffcd2ddd51 of D:\Users\Dima\Work\.NET2\lib.net\lib\bin\vs2017_nets2.0_Debug\lcpi.lib.nets2_0.debug.dll not found. Can be ignored if not a NUnit project. [11/3/2017 OF 9:14:44 AM Warning] Dependent Assembly netstandard, Version=2.0.0.0, Culture=neutral, PublicKeyToken=cc7b13ffcd2ddd51 of D:\Users\Dima\Work\.NET2\lib.net\ntest\bin\vs2017_nets2.0_Debug\lcpi.lib.ntest.nets2_0.debug.dll not found. Can be ignored if not a NUnit project. [11/3/2017 OF 9:14:44 AM Informational] NUnit VS Adapter 2.1.1.0 discovering test is finished [11/3/2017 OF 9:14:44 AM Informational] ========== Discover test finished: 0 found (0:00:01,0705979) ========== Found a. net Framework app fails with "Could not load file or assembly ' netstandard, Version=2.0.0.0 '" You need to add a reference to NETStandard. Library. NETFramework package to get this dependency now. Do not prompt - where I can find this "NETStandard. Library. NETFramework"? On nuget it is not present and on its system disk too is not watched UPD. Esteemed further. Found other helps and documents which should be loaded in a head

4

Re: How to test the assembly under.NET Standard v2?

Hello, Kovalenko Dmitry, you wrote: > I Try to drag the library on.NET Standard v2 [VS2017] Decided to go from simple to the difficult. Made a trivial test project as it is written in this document - Testing.NET Core with NUnit in a Visual Studio 2017 It turned out. Then: 1. Disassembled to the base the main test project 2. Anew connected to it Microsoft. NET.Test. Sdk, NUnit, NUnit3TestAdapter 3. Connected to it files with tests and the link to library (Net Std v2) which should be tested. Tests appeared and even fulfilled. Everything, except tests for serialization (it is similar it in Net Std v2 is not supported). But with it I will understand then. To all who worried and mentally me supported - THANKS!