1

Topic: Qt static build linux

Linux Mint 18.1 mate 64bit. It is necessary to collect static build Qt 5.6.3. I have a wide experience of statics-assemblages in Windows, various versions, from 4th till 5.10 And here with  it does not turn out yet. That I do: - I put fresh  in Virtual Box; - I put in it guest additions, I organize  a folder; - I update libraries: apt-get update; apt-get install gcc g ++ make wget build-essential perl python \"^libxcb. *" libx11-dev libx11-xcb-dev libxcursor-dev libxrender-dev libxrandr-dev \libxext-dev libxi-dev libxss-dev libxt-dev libxv-dev libxxf86vm-dev libxinerama-dev libxkbcommon-dev \libfontconfig1-dev libharfbuzz-dev \libasound2-dev libpulse-dev libdbus-1-dev udev mtdev-tools webp \libudev-dev libglm-dev libwayland-dev libegl1-mesa-dev mesa-common-dev \libgl1-mesa-dev libglu1-mesa-dev libgles2-mesa libgles2-mesa-dev libmirclient-dev \libproxy-dev libgtk2.0-dev libgtk-3-dev libcups2-dev - I swing source codes from here: https://download.qt.io/official_release … 6.3.tar.xz - I unpack them in the in a house folder;-. / /configure-release-prefix/home/user/qt-src-5.6.3-opensource-confirm-license-static-accessibility-c ++ 11-opengl desktop-qt-zlib-nomake examples-nomake tests-nomake tools-skip xmlpatterns-skip qtconnectivity-skip qtdeclarative-skip qtlocation-skip qtquickcontrols-skip qtsensors-skip qttools-skip qtwebsockets-skip qtwinextras-skip qtwebchannel-skip qtwebengine-no-qml-debug-qt-sql-sqlite-qt-pcre-qt-xcb - configuring was successfully completed, qmake has been collected, I launch make After start the output of the same line in the console, in flow of minutes 20 begins:/home/user/qt-src-5.6.3/qtbase/bin/qmake-o Makefile qt.pro Thus it is visible that there is a removal of file Makefile and its creation and so it is a lot of times. It is more like as happens nothing. In the end in the console the message "the Purpose first is produced does not demand performance of commands" and on it all is completed. It was not possible to find out any dens. Precisely same was showed and in alt-kworkstation-8, the present, not in . What do I do not so? Thanks.

2

Re: Qt static build linux

Hello, Lexerys, you wrote: L> Linux Mint 18.1 mate 64bit. L> It is necessary to collect static build Qt 5.6.3. L> I Have a wide experience of statics-assemblages in Windows, various versions, from 4th till 5.10 L> And here with  it does not turn out yet. For what it's worth, I collected static Qt under  and similar problems did not meet. However, it was for a long time, became under Dew and  absolutely other dial-up of options (it was the assembly under the specific project, and all not used of Qt I threw out). I to myself specially then , here a file, there am exact command line: https://abf.rosalinux.ru/soft/rosa-imag … EPLOY.html It is possible to try to begin with this variant. If gathers, further already to understand, what distinctions give such effect. Personally suspicions cause in me-nomake tools and-skip qttools. They precisely are not necessary for the assembly?

3

Re: Qt static build linux

Hello, CaptainFlint, you wrote: CF> For what it's worth, I collected static Qt under  and similar problems did not meet. However, it was for a long time, became under Dew and  absolutely other dial-up of options (it was the assembly under the specific project, and all not used of Qt I threw out). I to myself specially then , here a file, there am exact command line: CF> https://abf.rosalinux.ru/soft/rosa-imag … EPLOY.html CF> It is possible to try to begin with this variant. If gathers, further already to understand, what distinctions give such effect. Personally suspicions cause in me-nomake tools and-skip qttools. They precisely are not necessary for the assembly? QtTools is , the designer, the linguist, dock, and others. For the assembly of the vital value have no. Tried to collect with your config, changed nothing. Probably, any nuances in a surrounding. I will try to collect more ancient version still.