1

Topic: Problem with Autocomplete

Kind time of days, to the project on MVC 5, I try to connect customary to me , persistently I receive the message -
"jQuery (...).autocomplete is not a function TypeError: jQuery (...)". Often enough used in MVC 3, especially with json requests as data source.
Google prompts, what there are no links to libraries, but jquery-ui and jquery in the project is, on page are declared, in what side to dig?

<script src = "~/Scripts/jquery-3.0.0.js"> </script>
<script src = "~/Scripts/jquery-ui.js"> </script>
<script type = "text/javascript">
$(document).ready (function () {
jQuery (' #detail ').autocomplete (
{
source: ["detail1";
"detail2";
"detail3"]
});
});
</script>

2

Re: Problem with Autocomplete

denis_viktorovich wrote:

$(document).ready (function () {
$(' #detail ').autocomplete (

and so?

3

Re: Problem with Autocomplete

Shocker. Pro;
"$ (...).autocomplete is not a function"

4

Re: Problem with Autocomplete

, autocomplete actually is present in jquery-ui.js?

5

Re: Problem with Autocomplete

Shocker. Pro;
Yes, and does not work and datapicker too, but works with

jQuery (document).ready (function () {
$.noConflict ();