1

Topic: Atom Editor

Kind day all.
Do not prompt, who can uses this editor - Atom?
How to wedge Package https://github.com/ksherlock/MUMPS.tmbundle
I can not understand in any way why does not work...
I try it now under Windows.
Thanks.

2

Re: Atom Editor

Valeriu, And under vsode as works? They now are based on one.

3

Re: Atom Editor

Not cutting in porridge;
Here - without problems.

4

Re: Atom Editor

In what a counter.
I tried different editors who is worse who is better.
Faced development on server side under Linux.
Clearly that there at me it is lifted without a graphic jacket so I come
Under WinSCP. Naturally here it is possible to wind different editors and to correct
There that the soul wants and JS, HTML, CSS, MUMPS, etc.
For example Notepad ++ copes HTML than for example VS Code is better,
For that it is better in JS...
Here also wanted to look that is able Atom.

5

Re: Atom Editor

6

Re: Atom Editor

DAiMor;
It is possible far off directly from its jacket on Windows to Linux???
Is available I will enter VSCode.

7

Re: Atom Editor

8

Re: Atom Editor

Clearly.
With Atom I will not communicate, if are not engaged in it.
Stopped on VSCode and Notepad ++ together with WinSCP.
I  on VPN work and VSCode  a little bit in comparison with Notepad ++
Well and if on a network I think without problems.
Thanks all. The question acts in film.

9

Re: Atom Editor

10

Re: Atom Editor

https://marketplace.visualstudio.com/it … vscode-cos
It, I think.

11

Re: Atom Editor

Valeriu;
Yes, it is necessary to deliver this extension, appears and  the code and connection to the server for compilation.
There is an autocompilation on saving.
Recently I added possibility to be connected to the server for review of routines and classes far off, but in a mode only review. This possibility is not included yet included in release.
Further more, we will develop. VSCode powerful enough editor, is a lot of to make there and we can easily surpass Atelier which by the way already any more will not be .

12

Re: Atom Editor

DAiMor;
I as understood it for the modern versions Cache'
Old it is not given. wink

13

Re: Atom Editor

Valeriu wrote:

DAiMor;
I as understood it for the modern versions Cache'
Old it is not given. wink

it is true, supports only versions which support Atelier. The same is used API.

14

Re: Atom Editor

And how about Sublime Text 3?
I see very bright.
And plug-in MUMPS was installed without problems.

15

Re: Atom Editor

Valeriu wrote:

And how about Sublime Text 3?
I see very bright.
And plug-in MUMPS was installed without problems.

SublimeText3 bright, yes, I used it what that time. The interesting fact in that that it was long enough in  versions. And by the way it after all paid actually.
So it is not especially interesting, in respect of the writing of plug-ins under it. To complete at least for one editor.